yum -y install gcc报错

分类:报错故障维修网浏览量:2086发布于:2020-09-19 06:17:21

你需要安装你系统上glibc版本的glibc-headers. glibc=2.3.4-2.25 进行在线安装或升级gcc. 补充:yum命令是Redhat Linux系统的命令. ,cyoxfr

可能是因为网络原因,你的yum源的服务器反应不正常.可以从下面几方面着手.1,确认你的机器是否可以正常上网.2,如果能,请在firefox里试着打开上面提到的网址,看一看是否能正常访问.比如确认一下是否能正常访问 http://centos.ustc.edu.cn/centos/6.4/os/x86_64/repodata/repomd.xml

先后顺序都有提示,你可以强制去除依赖安装,加参数--nodepas,但可能出现问题,最好的办法就是配置yum源,yum可以很好的解决包依赖关系,然后yum install gcc* -y

参考:http://www.51ou.com/browse/nginx/60668.html 直接安装一个nginx的yum源文件.

---菜鸟认为:你确定把所有的gcc编译都安装了?直接#yum -y install gcc*

1、检查网络,确保网络连接正常2、尝试修改yum源3、修改yum源为阿里云的yum源方法如下:① 备份之前的CentOS-Base.repo地址cd /etc/yum.repos.d/mv CentOS-Base

错误:没有可用的CC编译工具在你的$PATH中所以有两种可能: 1 你的系统中本身就没有编译器用来编译GCC的源代码. 2 你的编译器不在$PATH中,所以不能调用,要转到相应的目录中去.

内存不足编辑yum的配置文件vi /etc/yum.conf加入exclude=filesystem保存退出,重新yum update 查看原帖>>

你可以使用code blocks,如果是ubuntu的话,在软件中心直接输入code blocks就可以直接安装的,里面有GCC,我也是用那个编译器的,感觉蛮好用的.就是有一点不好,界面是全英文的,第一次用估计会有点不习惯.

可以从以下两个方面判断:1.你联网了吗?2.你用的yum安装哪一个软件或包,有些在centos里面是没有yum源的,这时,你安装某些软件就不会成功.需要手动修改centos yum 增加源,有些软件无法yum,你可以下载源文件,编译安装.